home *** CD-ROM | disk | FTP | other *** search
/ Chip 2007 January, February, March & April / Chip-Cover-CD-2007-02.iso / Pakiet bezpieczenstwa / mini Pentoo LiveCD 2006.1 / mpentoo-2006.1.iso / livecd.squashfs / var / db / pkg / dev-util / pkgconfig-0.20 / pkgconfig-0.20.ebuild < prev    next >
Text File  |  2006-04-25  |  836b  |  34 lines

  1. # Copyright 1999-2006 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. # $Header: /var/cvsroot/gentoo-x86/dev-util/pkgconfig/pkgconfig-0.20.ebuild,v 1.12 2006/03/30 18:22:43 flameeyes Exp $
  4.  
  5. inherit flag-o-matic
  6.  
  7. MY_P="pkg-config"-${PV}
  8. DESCRIPTION="Package config system that manages compile/link flags"
  9. HOMEPAGE="http://pkgconfig.freedesktop.org/wiki/"
  10.  
  11. SRC_URI="http://pkgconfig.freedesktop.org/releases/${MY_P}.tar.gz"
  12.  
  13. LICENSE="GPL-2"
  14. SLOT="0"
  15. KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ~ppc-macos ppc64 s390 sh sparc x86 ~x86-fbsd"
  16. IUSE="hardened"
  17.  
  18. DEPEND=""
  19.  
  20. S=${WORKDIR}/${MY_P}
  21.  
  22.  
  23. src_unpack() {
  24.     unpack "${A}"
  25.  
  26.     use ppc64 && use hardened && replace-flags -O[2-3] -O1
  27. }
  28.  
  29. src_install() {
  30.     make DESTDIR="${D}" install || die "Installation failed"
  31.  
  32.     dodoc AUTHORS ChangeLog NEWS README
  33. }
  34.